Fibre connections VLAN
Moderator: Moderators
Fibre connections VLAN
Hi all
In New Zealand and I suspect the rest of the world Fibre is becoming the norm. It appears that you can now use your own router (Gargoyle)to connect to the Fibre ONT. The problem is my provider requires a VLAN of 10.
It would be really good if we could have a VLAN input box
In New Zealand and I suspect the rest of the world Fibre is becoming the norm. It appears that you can now use your own router (Gargoyle)to connect to the Fibre ONT. The problem is my provider requires a VLAN of 10.
It would be really good if we could have a VLAN input box
Re: Fibre connections VLAN
This is my exact same problem
https://forum.openwrt.org/t/vlan-on-wnd ... ort/153836
Im working through a command line solution
https://forum.openwrt.org/t/vlan-on-wnd ... ort/153836
Im working through a command line solution
Re: Fibre connections VLAN
Code: Select all
uci set network.wan.device='eth0.10'
Re: Fibre connections VLAN
Code: Select all
uci set network.wan.device='eth0.10'
uci set network.wan6.device='@wan'
uci commit network
Before/etc/config/network
Code: Select all
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd85:346e:3122::/48'
config device
option name 'br-lan'
option type 'bridge'
list ports 'eth1.1'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
config interface 'wan'
option device 'eth0.2'
option proto 'dhcp'
config interface 'wan6'
option device '@wan'
option proto 'dhcpv6'
config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'
config switch_vlan
option device 'switch0'
option vlan '1'
option ports '2 3 4 5 0t'
config switch_vlan
option device 'switch0'
option vlan '2'
option ports '1 6t'
Code: Select all
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd85:346e:3122::/48'
config device
option name 'br-lan'
option type 'bridge'
list ports 'eth1.1'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
config interface 'wan'
option device 'eth0.2'
option proto 'dhcp'
config interface 'wan6'
option device 'eth0.10'
option proto 'dhcpv6'
config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'
config switch_vlan
option device 'switch0'
option vlan '1'
option ports '2 3 4 5 0t'
config switch_vlan
option device 'switch0'
option vlan '2'
option ports '1 6t'
Re: Fibre connections VLAN
I'll work on this, but i can't test it, i will need testers.
The only complication is making it work for both DSA and older style switch setups at the same time, AND, making sure that Gargoyle doesn't blow it away when resetting anything.
The only complication is making it work for both DSA and older style switch setups at the same time, AND, making sure that Gargoyle doesn't blow it away when resetting anything.
https://lantisproject.com/downloads/gargoylebuilds for the latest releases
Please be respectful when posting. I do this in my free time on a volunteer basis.
Please be respectful when posting. I do this in my free time on a volunteer basis.
Re: Fibre connections VLAN
Thank you
I'm watching YouTube videos on how to VLAN untag to use the ISP-provided router for phones only.
I am not the only person to ask this question
https://www.geekzone.co.nz/forums.asp?f ... cid=250644
Re: Fibre connections VLAN
https://youtu.be/d3aYMqt-b_cboth DSA and older style switch setups
Re: Fibre connections VLAN
The more I read the more I understand your postI'll work on this, but i can't test it, i will need testers.
The only complication is making it work for both DSA and older style switch setups at the same time, AND, making sure that Gargoyle doesn't blow it away when resetting anything.
How is any regular person going to use OpenWRT VLANS?
Re: Fibre connections VLAN
I did some tests and the above commands faileduci set network.wan.device='eth0.10'
uci set network.wan6.device='@wan'
uci commit network
I wonder if it's a DSA issue (new format)?
The ISP's allow third-party routers and my unifi USG just works out of the box.